/ Id-Extras Forum / V-justify not working

  • Author
  • #7130 Reply


      I’m new to V-justify and am just trying it for the first time.

      I tried a frame where all paragraphs use a paragraph style with space after set to 4.2 mm, and I set V-justify to a minimum of 2 mm and a maximum of 7 mm, but when I click Justify it does nothing!

      I suspect that it could be due to me using an object in the first line of each paragraph to create a ‘window’ under the first word – as this is known to block Indesign’s own justification feature. But on the V-justify page I did not see this listed between the known limitations.

      Other than this it cannot see why it should not work. And if this ‘is’ the cause then I would probably have no use out of this script, as I use these objects constantly for creating windows.

      Please help.

      Thank you

      #7131 Reply

        Hi Elyokim,

        It sounds like it should work from what you’re describing, but perhaps there isn’t enough flexibility in those value to get it to the bottom of the frame? If you Shift+Click on the Justify button, does it work?

        I’m familiar with the bug that prevents InDesign from applying vertical justification if there are dropcaps on the page, but V-Justify definitely works in this case and is not affected by dropwords.

        If shift-clicking doesn’t work, I’d be happy to take a look at your file and see if I can figure out what’s going on. So feel free to send me the file.


        #7133 Reply

          Sorry I didn’t realise there was a reply as I was expecting an email reply or notification.

          The values I entered are way more than enough to enable it to justify, and shift-clicking didn’t work either.

          Please advise what else I could try.

          Thank you

          #7134 Reply

            Feel free to send me the file and I’ll take a look.

            To get emails, BTW, there’s a checkbox at the bottom of the thread, which I think needs to be checked…


            #7136 Reply

              Sent you the file yesterday.

              Please let me know what you find.

              BTW I cannot see the checkbox for email notification.

              Thank you

              #7137 Reply

                Did you get my file?

                I need justification for pages 54 to the end.

                I tried running the script on page 54, but it did not work.

                Please let me know what you find.

                Thank you

                #7138 Reply

                  Yes, I did, many thanks.

                  I have an upgrade ready for V-Justify that will solve the issue. Will try to send it later today.

                  #7139 Reply

                    Thank you very much for the great service!

                    Looking forward to receiving the upgrade.

                    #7141 Reply

                      Version 1.6.0 is ready for download. Download it from the My Account page, here: https://www.id-extras.com/shopping-cart/my-account/

                      You were correct to state that the anchored objects you were using to create dropwords invoked the famous InDesign bug that stops its own vertical justification working.

                      Because InDesign’s vertical justification doesn’t work, V-Justify is not able to figure out what the justification “target” is in the pages of your document.

                      In version 1.6.0 there is an option to set the justification target to the bottom of the frame. For most pages in your document (except where there are footnotes) this fixes the issue.

                      For pages that include footnotes, it is still necessary to use the “As reported by InDesign’s own vertical justification” as the target, and then, because of the anchored objects, it won’t work. (This is one of the reasons is strongly recommend using Id-Extras’s DropWord script, which creates dropwords without resorting to anchored objects!)

                    Viewing 9 posts - 1 through 9 (of 9 total)


                    Reply To: V-justify not working
                    Your information: