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Introduction

Footwork goes beyond the automatic footnoting capabilities offered by 
InDesign, allowing you to:

1.	 Create multi-column 
footnotes for documents that 
have a single-column layout.

2.	 Create single-column 
footnotes for documents 
that have a multi-column 
layout (InDesign’s automatic 
footnotes can do this 
from InDesign CC 2017 
onward. Footwork adds this 
capability to older versions 
of InDesign.)

3.	 Create run-on footnotes 
where each footnote 
continues on the same line as 
the previous footnote.

4.	 Have much more control 

over how space on your 
pages is allocated between 
page text and footnote text.

5.	 Use any placed graphic or 
InDesign object as a divider 
between your footnotes and 
the page text.

6.	 Allow footnotes to begin on 
a different page than the 
footnote reference, if desired.

7.	 Create footnotes nested 
within your footnote text, for 
a total of 4 parallel texts on 
a single page (main text with 
footnotes + footnote text 
with footnotes).

System requirements

Macintosh or Windows InDesign CS4 and higher.

“�Footwork is an essential 

tool for automating 

complex layouts with 

multi-column or run-on 

footnotes!”
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Installation

Install the scripts as normal for any InDesign script:

1.	 Unzip (extract) the zip folder containing the scripts. The resulting 
Footwork folder contains 2 scripts: FootworkUtilities and 
Footwork.

2.	 Display the Scripts panel on the screen (Window > Utilities > 
Scripts).

3.	 Right-click on the User folder in the Scripts panel, and choose 
Reveal in Finder (Mac) or Reveal in Explorer (Windows).

4.	 Copy the Footwork folder into the folder that is highlighted in the 
Finder/Explorer.

5.	 Return to InDesign, and you should see the scripts appear in the 
User folder in the Scripts panel. You may need to flip the User 
folder closed and open once using the triangle to the left of the 
word “User”.

More information on how to install scripts can be found at 
adobe.ly/PgvxGB. Watch a free Lynda.com video about how to install 
a script at bit.ly/3Qv88ae

Usually, the Application folder has higher permissions, so if you find 
the script is not running when placed in the User folder, try placing it 
in the Application folder and running it from there.
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The Id-Extras menu

For quick access to all your Id-Extras.com InDesign add-ons, including 
Footwork, an optional Id-Extras menu can be added to InDesign’s 
main menu.

To enable the Id-Extras menu, click on the “About...” button in the 
main Footwork window, and tick the “Create menu item” checkbox.

It is necessary to restart InDesign for the menu item to appear.

To remove the Id-Extras menu, uncheck the “Create menu item” 
checkbox for all your Id-Extras add-ons. When no add-ons appear 
under the Id-Extras menu, the menu item itself will disappear.
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Quickstart: How to use Footwork for the first time

1.	 Open an InDesign document that contains at least one footnote 
created with InDesign’s built-in footnote feature.

2.	 Select one of the frames in a story that contains footnotes.

3.	 Double-click on the Footwork script to run the script, and click on 
the Detach tab.

4.	 Leave the default settings as is (they should look like the screenshot 
opposite), and click Detach.

The footnote text will be removed from each page, and placed in a 
frame on the pasteboard just below the first page of the story. This 
frame will be selected when the script is finished. You won’t see any 
of the footnote text in this frame, since it is overset. If you want to 
see the footnote text, choose Edit > Edit in Story Editor.

New in version 3: Check the new “Detach as endnotes” checkbox 
to convert your existing footnotes into InDesign endnotes. See page 7 
for more details.

5.	 Display your Object Styles panel on the screen (Window > Styles > 
Object Styles).

6.	 Edit the Footnotes Object Style to specify the number of columns 
that you want for your footnote text. Note that the number of 
columns is set to 2 by default.
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7.	 If your story consists of multi-column text frames, create an object 
style that specifies the number of columns, and assign this object 
style to the first frame of the story. If your story uses single column 
frames, you can skip this step.

8.	 With the footnote frame selected, double-click on the the 
Footwork 3 script.

9.	 Leave the default settings (they should look like the screenshot 
opposite), and click Compose.

Footwork will go through the document, recomposing each page 
and positioning footnote text in the proper location on each page. A 
progress bar is displayed while the script runs.

10.	When the script is finished, you can either leave the dialog box on 
the screen for convenience, or click Close.
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11.	 �Footwork provides an easy way jump from footnote reference to 
footnote reference in the document. If you’ve closed the Footwork 
dialog box, run the Footwork script again to display the dialog. Then 
click the Check GREPs button.

12.	�A list of each footnote reference in the text will be displayed. Click 
on a number to jump to that footnote reference. This dialog also 
provides a convenient way to renumber footnotes and identify 
problem footnotes. See “How to renumber footnotes” on page 14 
for more about this feature.
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What’s new in version 3

Version 3 of Footwork introduces three important new features:

(1) Full support for endnotes-as-footnotes. A new option, 
“Detach as endnotes” can be found under the Detach tab. This detaches 
the existing InDesign footnotes and converts them to endnotes. 
Footwork will then compose pages using these endnotes. The result is 
endnotes disguised as footnotes.

This feature is only available, and will only be visible, for 
InDesign versions that support endnotes (CC 2018 and up).

The advantage of doing this is that the connection between the 
footnote references and the footnotes themselves is live. Deleting 
a footnote reference in the main text will delete the corresponding 
footnote, and all remaining footnotes will be instantly renumbered. 
Likewise, inserting a new footnote in the main text (= a new InDesign 
endnote [Type > Insert Endnote]) will automatically make room for 
a new footnote in the appropriate place in the footnote story and 
instantly renumber the remaining footnotes.

This behavior is more intuitive than having a plain text story acting as 
footnotes. In that case, adding and deleting footnotes required several 
more steps and was more cumbersome, and manual renumbering 
(using Footwork’s renumbering option) was required each time.
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Note that even with endnotes, it is still necessary to recompose the text 
when footnotes are added or removed.

I recommend always using the new “Detach as endnotes” option 
unless (a) your document requires real endnotes as well as footnotes, 
or (b) you need more flexibility with footnote numbering than using 
InDesign’s endnotes provides.

(2) Reattach footnotes. A new option to reattach Footwork’s 
footnotes is now available under the Detach tab (see opposite).

Whether you’ve detached the original InDesign footnotes as plain text 
or as endnotes, it is now possible to convert these detached footnotes 
back to regular, live, InDesign footnotes.

To do so, select a frame from a Footwork-managed story, and click on 
the Reattach button. The detached footnotes will be converted back to 
regular InDesign footnotes.

This might be useful in a number of scenarios: (1) You need to add (or 
delete) many footnotes. InDesign footnotes are updated automatically 
in the layout, so it might be easier to do this with real footnotes. (2) A 
Word file of the most up-to-date text is needed. Edits are often made 
to the typeset pages, so the typeset version of the document is probably 
the most up-to-date. By converting Footwork notes back to regular 
footnotes and exporting the text to Word, you will have an up-to-date 
version of the document in Word.
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(3) Page-side options. Under the Footwork tab, a new option to 
only run Footwork on left-hand or right-hand pages is available.

This can be useful if the document design reserves recto or verso pages 
for images or diagrams, or perhaps for a side-by-side translation of the 
text on the opposite page.

From the dropdown (shown opposite), select whether you want 
Footwork to run on both sides of the spread, or on left-hand or right-
hand pages only.
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How to edit the document or footnote text

Once you’ve run Footwork successfully and Footwork is managing 
the layout of our footnotes, you can edit the page text, or the text for 
individual footnotes at any time, using any tools or techniques you 
would normally use. The only consideration is that as you make large 
edits, the footnote layout may become “unsynchronized” from the 
footnote references. In other words, you may end up with a footnote on 
a different page than the footnote reference.

This just means that as the document is edited, you will occasionally 
need to rerun the Footwork script and allow Footwork to recompose 
the layout of each page. See “How to recompose pages after editing” on 
page 13 for instructions.

How to add a footnote

1.	 New in version 3: If you’ve used the new “Detach as endnotes” 
feature, your Footwork footnotes are actually InDesign endnotes 
in disguise. In this case, all you need to do to add a footnote is to 
add an InDesign endnote in the desired location (Type > Insert 
Endnote). You can then skip the followings steps 2 though 6.

2.	 Type the footnote reference character in desired location in the text.

You don’t need to worry about getting the reference number 
correct. You can type any number when you add a footnote 
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reference, as the footnotes can be easily automatically renumbered 
later.

3.	 Apply the FootworkMainText Character Style to the character.

4.	 If the page already has at least one footnote, enter the text for 
the new footnote in the proper location in the footnote frame. If 
the page doesn’t contain a footnote, navigate to a previous page 
that contains a footnote, and edit the footnote text in Story Editor 
(Edit > Edit in Story Editor).

Enter the text for the new footnote in the correct sequence (that is, 
after the previous footnote and before the next footnote). Apply the 
desired paragraph style to the footnote text.

5.	 Type the footnote number at the beginning of the footnote. You 
don’t need to worry about typing the correct number. You can 
type any number, as the footnotes can be easily automatically 
renumbered later.

6.	 Apply the Character Style FootworkFootnotes to the footnote 
number (be careful to apply it to the number only, not any 
punctuation or spaces that may be after the number).

After adding a footnote, the footnote layout will likely no longer be 
synchronized with the footnote references. You will probably want to  
rerun the Footwork script and allow Footwork to recompose the layout 
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of each page. See “How to recompose pages after editing” on page 13 
for instructions.

How to delete a footnote

1.	 New in version 3: If you’ve used the new “Detach as endnotes” 
feature, your Footwork footnotes are actually InDesign endnotes 
in disguise. In this case, all you need to do to delete a footnote is 
delete the endnote reference to that footnote in the main text. You 
can then skip the followings steps 2 and 3.

2.	 Delete the footnote reference in the text.

3.	 Carefully delete the footnote and its number from the footnote 
frame at the bottom of the page. Be careful not to leave an extra 
return character in the frame.

After removing a footnote, the footnote layout will likely no longer 
be synchronized with the footnote references. You will need to 
prompt Footwork to recompose the layout of the pages. See “How to 
recompose pages after editing” on page 13 for instructions.
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How to recompose pages after editing

After you’ve made extensive changes to footnote text or the 
text of your story, you will likely need to prompt Footwork to 
recompose the layout of your pages. However, Footwork has 
been written so that you don’t need to recompose the entire 
document every time. You can recompose  the document from 
where you’ve made changes and forward.

1.	 Select the text frame on the page immediately before the page 
on which you’ve made changes to the document or footnote 
text.

2.	 Double-click on the Footwork script if the Footwork dialog 
box is not already open.

3.	 To limit how far ahead in the document Footwork 
recomposes pages, choose a number from the Number of 
pages to add drop-down list. Choose No limit to recompose 
pages all the way to the end of the story.

4.	 Click the Compose button.

Every time you click the Compose button, Footwork 
will recompose pages of the selected story.
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How to renumber footnotes

New in version 3: If you’ve used the new “Detach as endnotes” 
feature, your Footwork footnotes are actually InDesign endnotes 
in disguise. In this case, InDesign automatically synchronizes the 
numbers and the “Renumber” feature described below will be disabled. 
To change the numbering options, use InDesign’s endnote numbering 
options (Type > Document Endnote Options…). The rest of this section 
therefore does not apply.

Otherwise, as mentioned above, Footwork doesn’t care about the 
footnote numbers. In other words, you can have two footnotes with 
the same number or symbol for the footnote reference. This provides 
tremendous flexibility. But you may need to tell Footwork to renumber 
the footnotes after edits have been made.

1.	 If the Footwork dialog box is not already open, double-click the 
Footwork script.

2.	 Click the Check GREPs button.

3.	 The dialog that appears displays all the footnote references in 
the document. In the dialog at right, a new footnote has been 
added after footnote 10, and this new footnote was also numbered 
with a 10.

4.	 Select the number where you want to begin renumbering, and click 
the Renumber button.

Before renumbering After renumbering
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5.	 Type the new number at which the numbering should begin, and 
click the Renumber button.

6.	 All the footnote numbers should now be sequential.

7.	 If you would like the footnote numbering to restart, tick the 
“Restart numbering” box, and from the dropdown choose whether 
to restart the numbering every page or every spread.
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How to locate and troubleshoot footnote problems

The Check GREPS dialog can help troubleshoot footnote problems. 

•	 Click on any row in the dialog box to display the footnote reference 
on the screen.

•	 A question mark next to a number indicates that the text of the 
footnote number and its reference are not identical.

•	 An × next to a number indicates that the footnote and its reference 
are not on the same page.

•	 If any footnotes are overset, this is indicated as well.
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How to create and use dividers

You can use any placed graphic or InDesign object (line, frame, group, 
etc.) as a divider between the footnote and main text frames.

1.	 Create the object you wish to use for the divider, and place it 
anywhere on the pasteboard.

2.	 In InDesign’s Layers panel, name the object Divider.

3.	 Run Footwork, and in the Footwork dialog box, make sure the 
Divider name exactly matches what you typed in the Layers panel.

4.	 Specify the desired Divider Offset in points.

5.	 Click OK to lay out the footnotes with dividers.

6.	 If any manual adjustments are made which cause the footnote 
divider graphics to be in the wrong position, click the Fix dividers 
button to return them to the correct location on the page.
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Script options

A	Gap height: The distance (in points) between the top of each 
footnote text frame and the bottom of each main text frame.

B	Gap even at top of page: If a page consists of only footnote text, 
should the gap height still appear above the footnote text frame?

C	Divider name: Type the name that you’ve assigned to your 
divider object on the pasteboard, if any. See “How to create and use 
dividers” on page 17.

D	Divider offset: Enter the amount of space, in points, that you 
want between the top of each footnote frame and the bottom of 
your Divider. A negative number can be used to position the divider 
graphic to overlap the footnote frame.

E	Fix dividers: This button resets the position of the dividers 
throughout the document. This is useful if any manual adjustments 
are made which cause the footnote divider graphic to be in the 
wrong position. Clicking this button while pressing the Shift key on 
the keyboard will remove all divider graphics from the document. 

F	Main story GREP name: Type the name of the saved GREP 
query that finds the footnote references in the main text. This is 
automatically populated with the correct name, and only needs to 
be changed for advanced use.
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G	Footnote story GREP name: Type the name of the saved GREP 
query that finds the beginning of each footnote in the footnote text. 
This is automatically populated with the correct name, and only 
needs to be changed for advanced use.

H	Check GREPs: This button displays a dialog box that lets you see 
at a glance if the footnote references in the main text correspond 
to the footnotes themselves, identify and fix various footnote 
problems, and renumber footnotes. See “How to renumber 
footnotes” on page 14 and “How to locate and troubleshoot footnote 
problems” on page 16.

I	Run-on footnotes and/or multi-column footnotes: This 
checkbox must be checked if footnotes are set in a run-on style, 
or in two or more columns. In either case, two or more footnotes 
can appear on the same line, unlike the standard case where each 
footnote begins a new paragraph. See “Advanced: How to create 
run-on footnotes” on page 27.

J	Footnotes may appear on next page: When this option 
is selected, if a footnote cannot begin on the same page as the 
reference to it in the main text, the footnote will appear on a later 
page. The advantage of this is that large white spaces at the bottom 
of the page are avoided, because they will be filled up with text. The 
disadvantage is that a footnote reference may appear on a page 
earlier than the footnote itself, which may be confusing to some 
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readers. In a text laden with long footnotes (for better or for worse), 
it is advisable to select this option.

K	Synchronization: The further to the right this slider is dragged, 
the greater the level of synchronization between the main text and 
footnotes. See “Advanced: How to use the Synchronization slider” 
on page 29.

L	Page-side options (new in version 3): Normally, Footwork 
runs both on left-hand (verso) and right-hand (recto) pages. In 
some books, you may want it to run only on left-hand or right-hand 
pages (perhaps recto pages are reserved for illustrations, etc.). 
Choose the required option from this dropdown menu.

M	Number of pages to add: Set how many pages from the selection 
forward Footwork should recompose when you click Compose. 
This can be useful as a time saving measure (perhaps you only care 
about the next 5 pages at the moment). If you want all the pages 
from your selection forward to be recomposed, choose No limit.

Tips

•	 You can undo the result of the Detach footnotes operation with a 
single undo command (Edit > Undo).
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•	 Each time that you click Compose in the Footwork dialog box to 
recompose pages, you can undo the operation with a single undo 
command (Edit > Undo).

•	 On Windows, you can cancel a lengthy recomposition of pages by 
holding down the Escape (Esc) key.
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Advanced: What the Detach operation does

For advanced use of Footwork, it is helpful to understand what the 
Detach operation does behind the scenes.

New in version 3: When “Detach as endnotes” is selected, the 
actions listed below are slightly different. The differences are 
highlighted in red.

Clicking on the Detach button:

1.	 Names the first frame of the story Chapter1 in the Layers panel.

2.	 Creates a text frame on the pasteboard below the page containing 
the first frame of the story, and names this frame Chapter1* in the 
Layers panel. This frame will be the first frame of a set of threaded 
frames that will hold all of the footnotes in the document. (If 
additional stories appear in the document with footnotes, these 
frames are numbered consecutively, as Chapter2, Chapter 3, etc.)�  
With “Detach as endnotes” selected, this text frame is actually an 
InDesign endnotes story.

3.	 Creates an object style named Footnotes (if this does not already 
exist in the document) for the footnotes frame, and assigns this 
object style 2 columns. If such a style exists already, it is not 
modified.
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4.	 Moves all the InDesign-generated footnotes into this frame, 
inserting a frame break character at the beginning so that all the 
footnote text becomes overset and doesn’t appear in the frame.

5.	 Creates a character style named FootworkMainText and assigns 
this style to each footnote reference in the text.

6.	 Creates a character style named FootworkFootnotes and assigns 
this style to the number at the beginning of each footnote.

7.	 Creates two GREP Find/Change queries named MainText and 
FootText that search for the character styles FootworkMainText 
and FootworkFootnotes respectively.�  
With “Detach as endnotes” selected, the GREP queries are named 
MainTextEndnotes and FootTextEndnotes.

If Use InDesign auto-numbering for Footnotes is selected, InDesign’s 
standard paragraph numbering feature will be applied to the first 
paragraph of each detached footnote. This option is not applicable if 
using the option “Detach as endnotes”.

Footwork accomplishes this by duplicating the paragraph style that is 
applied to the first footnote in the story, and adding the suffix “2” to the 
name of this paragraph style. InDesign’s paragraph numbering feature 
is then applied to this style.
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The auto-numbering for footnotes option can be convenient if you 
anticipate many changes to the footnote text, because the footnote 
numbering will update automatically. Note, however, that:

1.	 The footnote references in the main text will not update 
automatically. Moreover, it may be difficult to use Footwork’s 
renumbering feature without altering the footnote text in unwanted 
ways.

2.	 You will need to manually modify the automatically generated 
FootText GREP query, as a simple search for a character style 
may not work if that character style is applied to the automated 
paragraph numbers only.

3.	 You should disable the Make first footnote text frame empty 
option, otherwise the frame break character Footwork adds to the 
first text frame of the footnote story will also be numbered!

In short, use this feature with care!
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Advanced: How to set up a document without InDesign-
generated footnotes to begin using Footwork

Once you understand what the Detach feature does, you can use this 
knowledge to set up a document to work with Footwork from the 
beginning, without first using InDesign’s footnote feature. All you need 
to do is replicate some of what the Detach operation does:

1.	 Name the first frame of your story Chapter1 in the Layers panel.

2.	 Create a text frame for the footnotes on the pasteboard below the 
page containing the first frame of the story, and name this frame 
Chapter1* in the Layers panel.

3.	 Create an object style (you may name it Footnotes for clarity) for 
the footnotes frame, and assign this object style the number of 
columns desired.

4.	 Type a frame break character in the footnotes frame so that all 
future footnote text becomes overset and doesn’t appear in the 
frame.

5.	 Create a character style named FootworkMainText (or any name of 
your choosing).

6.	 Create a character style named FootworkFootnotes (or any name of 
your choosing).
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7.	 Create two GREP Find/Change queries named MainText and 
FootText (or any name of your choosing) that search for the 
Character styles you created in steps 5 and 6 above.

8.	 Type your first footnote reference in your text, and assign it the 
Character style you created in step 5 above.

9.	 Use the Story Editor to type your first Footnote into the footnote 
frame. Assign the Character style you created in step 6, above, to 
the number in front of the footnote text.

10.	Type the names of the GREP queries you created in step 7, above, 
into the appropriate fields in the main Footwork window (fields F 
and G in the screenshot on p. “Script options” on page 18 above).

Now you are ready to run the Footwork script for the first time, and 
continue adding and editing footnotes in the document.
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Advanced: How to create run-on footnotes

With run-on footnotes, two or more footnotes can appear on the 
same line, unlike the standard case where each footnote begins a new 
paragraph.

To create run-on footnotes, select the Create run-on footnotes option 
under the Detach tab of the main Footwork window. 

Then, after you run Footwork, if you choose Type > Show Hidden 
Characters you will see that Footwork inserts 2 em-spaces and a 
regular space between each footnote. This pattern is used by default 
and works well since em- and en-space characters are non-breaking. 
The em-space keyboard shortcut is command+shift+m (Mac), 
ctrl+shift+m (Windows). You don’t have to use this combination of 
spaces. You can choose any type of whitespace to insert between your 
footnotes.
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Since multiple footnotes may appear on the same line, it is 
sometimes necessary to insert a manual frame break before 
the appearance of a new footnote on a line (to ensure that the 
footnote begins on the same page as its footnote reference 
in the main text). Checking the Run-on footnotes and/or 
multi-column footnotes option in the Footwork dialog box 
allows Footwork to insert (and remove, if necessary) such 
manual page breaks. Deselecting this option means that if 
one footnote on a line cannot appear on a certain page, all 
footnotes on that line will also be carried over to the next 
page. Again, selecting this option is only necessary if the 
footnotes are set in run-on style (a single long paragraph) 
or multiple-column style. If each footnote is a separate 
paragraph and a single-column footnote layout is used, leave 
this option unchecked.
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Advanced: How to use the Synchronization slider

Footwork’s synchronization slider provides control over the split point 
of footnotes that continue onto the next page.

Most programs (including Microsoft Word, InDesign, and Footwork 
with the slider set to zero) will set the first line of main text containing 
a footnote reference, and then continue by setting the entire footnote, 
before going back and setting another line of main text.

So in a case where the last footnote on the page is long, and continues 
onto the next page, the result is that there will be a single line of main 
text on that page (containing the reference to the long footnote) and all 
the rest of the page will be taken up by the long footnote.

This is not so elegant. One feels it would be better if there were more 
lines of main text on the page, and fewer lines of footnote text.

The synchronization slider allows this level of control. Let’s say it is set 
at level 6. This tells Footwork to divide the footnote into 6 parts, and 
likewise to divide the main text between this footnote reference and the 
one after it into 6 parts. (This division is not seen on the page – it’s an 
internal calculation only.) Now Footwork will ensure that once it has 
set the first sixth of the footnote, it will go back and set the first sixth of 
the main text. When it finishes doing that, it will set the second sixth of 
the footnote, and then the corresponding second sixth of the main text, 
and so on.
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The result is that the division of the last footnote on the page is more 
logical and less forced, and ensures that there is approximately the 
same proportion of main text as there is footnote on the page.

There are 8 settings on the slider. The higher the number, the better 
the synchronization.
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Advanced: Using GREP for complex footnote formats

As noted earlier, the Detach operation creates two GREP Find/Change 
queries named MainText and FootText that search for the Character 
styles FootworkMainText and FootworkFootnotes respectively. These 
GREP queries are the backbone of Footwork, since Footwork assumes 
there is always a 1-to-1 relationship between each footnote and its 
reference.

First, Footwork runs the MainText find/change query to find all 
references to footnotes in the main text. Let’s say it finds 50 references. 
Next, Footwork will run the FootText find/change query to find the 
beginning of all footnotes in the footnote story. It should find 50 such 
beginnings, corresponding to the 50 references.

Armed with this knowledge, you can create any GREP expression for 
the MainText and FootText queries that you would like, as long as the 
expression accurately and reliably finds your footnote references and 
beginnings of each footnote. 

This provides tremendous flexibility for creating footnotes with 
different reference styles beyond simple numbering.

If you are working on several different books at once, and each one 
needs a slightly different GREP search to find its footnote references 
and footnotes, you can save multiple pairs of GREP queries, one for 
each book. Use a different name for each pair, and update the names in 
the Footwork window appropriately.
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Advanced: Using the FootworkUtilities script

This script display a small window with two buttons which add or 
remove one text line (or the minimum number of lines possible, 
depending on your Keep Options) to the selected text frame. If either 
of the buttons is clicked while pressing Shift, it adds or removes one 
line to the selected frame, and adds or removes one line from the 
corresponding text frame (i.e., adds 1 line to footnotes, removes 1 line 
from main text, or vice-versa).

It also displays the distance between the bottom of the main frame and 
the top of the footnote frame.

This is useful when you need to make manual adjustments to the 
automated layout.

Advanced: How Footwork handles blank pages

If there are any blank document pages after the story being worked on, 
those blank pages will be used for new text frames and footnote frames 
as necessary when Footwork recomposes pages. If no blank pages are 
found, Footwork creates new document pages as needed. Hint: In 
some cases, you may be able to speed up the operation of Footwork by 
inserting sufficient blank pages at the end of the story before running 
Footwork.
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Change Log

Version 1.9.2: Supports continued tables up to 60 pages long.

Version 2.0.0: Fixes renumber bug in cases where there are more 
footnotes than references to footnotes. Added option to restart 
numbering every page or spread.

Version 2.0.1: Fixes a bug preventing the Id-Extras menu from being 
created.

Version 2.0.2: Optimizes the Detach routine for stories with 1000+ 
footnotes.

Version 3.0.0: New features: (1) Supports using InDesign endnotes 
as Footwork footnotes. (2) Adds a “Detach as endnotes” feature. 
(3) Adds a “Reattach” feature, to convert Footwork footnotes back into 
live InDesign footnotes. (3) Adds page-side options, allowing Footwork 
to flow text exclusively on recto or verso pages.
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Warranties and disclaimers
Footwork is provided “as is.” Bookraft Solutions, Israel, makes no express, implied, 
or statutory warranty of any kind with respect to the product, clients transactions, or 
those products obtained including, but not limited to, any warranty of performance, 
merchantability, satisfactory quality, noninfringement, or fitness for a particular 
purpose. in no event will Bookraft be liable to client or any other party for any 
damages, even if Bookraft or any company representative has been advised of the 
possibility of such damages. The end user bears the entire risk as to the use of the 
product. To the extent an implied warranty cannot be excluded, such warranty 
is limited in duration to the express warranty period. Because some states or 
jurisdictions do not allow limitations on the duration of implied warranties, the 
above limitation may not apply. The downloading and/or use of all products is done 
at client’s own discretion and risk and with client’s agreement that client will be 
solely responsible for any damage to client’s computer system, loss of data, or other 
harm that results from such activities. Bookraft assumes no liability for any computer 
virus or other similar software code that is downloaded to client’s computer or device 
in connection with client’s use of the products or client’s transactions. No advice 
or information, whether oral or written, obtained by client from Bookraft or the 
products shall create any warranty not expressly stated in the agreement. 

“ALWAYS MAKE A BACKUP FIRST!”
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