/ Id-Extras Forum / Script Error Message [Footwork]

  • Author
  • #6140 Reply
    dfrac

    I’m trying to test Footwork and have installed the Trial Version on a 15-page InDesign document. It appears in my InDesign Script User Folder, but unfortunately, I’m not able to run the script, I’m getting the following/attached error:

    Cannot find a footnote text frame labelled*.

    Can you please provide some assistance, I’m running CC2020 and would love to be able to design multi-column footnotes combined with a single column layout.

    Thanks,

    #6222 Reply
    ~~Ariel~~
    Participant

    Hi Dfrac,
    The simplest way to get this to work is to start with a document that has footnotes, and then to use the “Detach” function in Footwork to detach the footnotes. When you allow Footwork to detach the footnotes, it sets everything else up so that it just works.
    However, if you cannot do that because the footnotes are supplied as a separate text, then there are a few steps that have to be taken and these are described in the User Guide starting on p. 17.
    The basic error message you’re getting is saying that Footwork expects you to tell it which text frame contains the footnotes, and which frame contains the main text. You should give the first frame of the main text some name in the Layers panel (make sure to name the text frame, and not the layer its in). Then you should give exactly the same name to the first text frame of the footnotes text, but add a * at the end. So if the first text frame of the main text is called “Chapter1” in the layers panel, the first frame of the footnote text should be called “Chapter1*”.
    But since other steps are required as well, for testing purposes and until you get a hang of the software, I really recommend starting with some text that has regular InDesign footnotes, and then using Footwork to detach them.
    The User Guide comes with a Quick Start section (on p. 4).
    Hope that helps, if you have any other questions post back!

    #6223 Reply
    dfrac

    Thanks Ariel,

    The issue is, both the Main body text and Footnote text, are coupled in a single text box. This is how InDesign treats Placed Word Docs w/ Footnotes. I tried also, with an InDesign file where the Footnotes have been converted in Word to Endnotes, as this creates an independent text box for the Endnotes. I change both text frame names in the layer panel, and ran the script—but this only produced a very small pop-up with a + and –

    My only guess is that I’m possibly doing something wrong with the Inport setting from Word??

    #6224 Reply
    ~~Ariel~~
    Participant

    Hi Dfrac,
    The first step with Footwork is to use the “Detach” function.
    So, open an InDesign document that has regular footnotes (“in a single text box”).
    Select that text frame, and run Footwork.
    In Footwork, click on the “Detach” tab, and click on the “Detach” button to detach the footnotes.
    You can now return to the main tab and click on the “Compose” button to layout the the text.
    This is all explained in the User Guide that comes with the demo download, in the Quick Start section (on p. 4).
    Thanks,
    Ariel

Viewing 4 posts - 1 through 4 (of 4 total)
Reply To: Reply #6224 in Script Error Message [Footwork]
Your information: