/ Id-Extras Forum / DeepLTranslate3.2.1 doesn’t Work

  • Author
  • #8016 Reply

      Hello, I’m a long time user of Translate.

      I don’t know why but nothing is working anymore. I tried many languages.

      DeepLTranslate3.2.1 doesn’t output any error message but removes all the text.

      GoogleTranslate2.5.1 shows an error message: TypeError: Undefined is not an object – Line 1073 –  The Script will now quit.

      I tried with older version of DeepLTranslate 3.1.4 that used to work fine, and same problem, but it doesn’t remove all the text, it replace the text with one word “Undefined”

      MacBook Air M1 – InDesign 19.3

      #8018 Reply

        Hi Rohan,

        Sorry to hear it’s not working for you. I don’t think it’s a specific problem with DeepL, because it’s being used all the time.

        So either it’s something to do with the specific file – in which case, could you send it to me to check?

        Or maybe your computer is blocking access to our server?



        #8022 Reply

          I have the same issue.

          TypeError: undefined is not an object

          Line: 318

          The file is quite heavy, about 28 pages. How can I proceed, can I send the IDML for you to look at?

          #8023 Reply

            Hi Stefan,

            Yes, please, I’d be happy to take a look at the InDesign file. If you were using a custom dictionary or glossary, make sure to send that too.

            But just as a preliminary check, and to see that it’s not some sort of Internet firewall or filter, have you tried translating, in a document, a simple sentence? Does that work?


            #8024 Reply

              I tried to simplify by only translating page 1, and I still get that error message. I also tried copying those text frames to a new document and I still get errors. I will send that document for you to look at.

              #8025 Reply

                Thanks for the documents.

                In addition to what I wrote in my email, please note that I can’t even open the documents you sent. I get the following error.

                Could you send an .idml document? Perhaps that would work better?

                #8026 Reply

                  Hi Stefan,

                  I managed to open the documents you sent now (I think in this case it was my firewall blocking the email).

                  But the document translates fine for me. This was tested on a Mac, with the latest ID 19.3.

                  I’m wondering: What language-version of InDesign are you using? I’ve got the English version.

                Viewing 7 posts - 1 through 7 (of 7 total)


                Reply To: DeepLTranslate3.2.1 doesn’t Work
                Your information: