/ Id-Extras Forum / FormMaker fields retain “$” symbol even after specifying no symbol.

  • Author
  • #6174 Reply
    Anagoge
    Participant

    Few questions:

    1) I’ve defined the formatting for a field. 2 decimal places, no currency symbol. When I export the form to Acrobat DC, the “$” symbol is there with 1 decimal place.

    2) I’m using Proxima Nova as the form font. I can normally see this font in fields within Acrobat by default. When I run FormMaker, it uses Times instead.

    3) I’ve read the help at help/formmagic. 7.1 says run a script to help identify InDesign’s internal font name to help with the Times issue. It doesn’t say how I go about running this script though.

    Please could you help? Much appreciated.

    Windows 10
    InDesign 16.1
    Acrobat 2021.001.20145

    Images showing issue:

    Correctly set up in InDesign: https://i.imgur.com/RBzl6SF.png

    Incorrectly displaying in Acrobat: https://i.imgur.com/63cbOy7.png

    #6333 Reply
    Anagoge
    Participant

    I think I’ve solved this. I just had to save to a new file, rather than overwriting an existing one. For some reason this worked.

    EDIT: Scratch that, found new issue:

    I can select “Date” as the format for a field, but Acrobat doesn’t give me the date popup option when doing it via FormMaker. Any ideas?

    #6334 Reply
    Ariel
    Keymaster

    Hi,
    (1) There was an issue with the currency formatting. I’ve uploaded a new version which solves a similar issue. Let me know if it helps. It can be downloaded here: https://www.id-extras.com/shopping-cart/my-account/
    (2) Did you get this working? It’s working for me fine with Proxima Nova (the font comes with a Creative Cloud subscription, so I tried it with that). I’m not needing to use the FontList method for it to work, it just works out of the box.

    Regarding the date field, is it working for you if you do it directly in Acrobat? I’m not managing to get a date picker to appear in Acrobat even if I do it manually!
    Ariel

    #6335 Reply
    Anagoge
    Participant

    Thanks for your help, Ariel!

    You can set dates in DC using a date picker if you set the field format to date. See here:

    https://i.imgur.com/Dk0spLD.png

    I can’t replicate this via FormMaker, however.

    #6336 Reply
    Ariel
    Keymaster

    Strangely, it’s not working for me in Acrobat at all. I’ve checked on Windows, with the latest version of Acrobat DC. I’ll have to play around with it some more, or test on a Mac or something.
    If it’s not working with FormMaker, though, I think you’ll need to go for a different option. Perhaps this: https://www.abracadabrapdf.net/utilitaires/utilities-in-english/magicdate-picker/
    It’s free. You’ll need to copy the document javascript that generates the date picker, and figure out out which other scripts to attach to each date field, but it should work.

    #6337 Reply
    Anagoge
    Participant

    I’m using Windows 10 and the latest version of DC too. I’ve also made a test file with a brand new field in InDesign, then create new form in DC and set this field to “Date”, which gives me the date picker. See screenshots for example:

    https://i.imgur.com/KMiwEms.png

    The date picker has been supported since the 2017 release of Acrobat, according to this page: https://helpx.adobe.com/acrobat/kb/support-for-image-and-date-fields-in-acroforms.html

    #6338 Reply
    Ariel
    Keymaster

    Right, that’s what I’m doing. Not sure why it doesn’t show up for me, I’ll need to look into it. Maybe there’s a setting somewhere that switches this off.

    #6339 Reply
    Anagoge
    Participant

    The only workaround I can find right now is doing what I can with FormMaker as normal, but then still create a new form in the PDF in DC after running FormMaker in DC. The field is already set to Date because FormMaker has set it up already, but doesn’t have the date picker. I have to set the format to “None”, and then set it back manually to “Date”. This then gives me the date picker.

    It’s almost like there’s two options for “Date” format and FormMaker’s using the non date-picker option.

    Is there somewhere I can be informed of an update for this issue or will you just reply to this thread once you’ve figured it out? Much appreciated!

    #6340 Reply
    Ariel
    Keymaster

    Hi Anagoge,
    It’s a bit weird. First of all, I cannot get the date picker to appear in Acrobat (the latest version) whatever I do.
    So I downloaded the free reader, and there, after creating the form with a date field in Acrobat, the date picker appears fine. (But still not in Acrobat!)
    Anyway, the good news is I’ve figured out that there is a bug in FormMaker that is preventing the date picker from appearing. It was also preventing the correct date format to be selected in the properties panel in Acrobat.
    I’ll do my best to release an update today which should fix these issues. Check back here in this thread. I’ll post a message when the update is available.
    Thanks for pointing out this issue!
    Ariel

    #6341 Reply
    Ariel
    Keymaster

    Version 3.0.8 of FormMaker has now been released. The date picker should now appear properly for date fields created with FormMaker.
    Additionally, if Date, Time, or Arbitrary Mask formatting is used in FormMaker in InDesign, this should now be reflected correctly in Acrobat’s Properties panel. (Previously, although the desired formatting worked, the formatting was not showing correctly under the Format tab in the Properties panel.)
    All current subscribers can download the latest version here: https://www.id-extras.com/shopping-cart/my-account/

    Ariel

    #6342 Reply
    Anagoge
    Participant

    Thank you so much for this, Ariel. The new update corrects the issues! Such quick bug fixing from you, very impressed.

    #6343 Reply
    Anagoge
    Participant

    Looks like I spoke too soon regarding one of my issues.

    On running FormMagic in DC, it removes the chosen font (Proxima Nova) and replaces with Times. However, on a form I built yesterday, it works fine. I can also reexport yesterday’s form from InDesign today and it works fine using FM 3.0.8.

    When I export today’s form from InDesign using FM 3.0.8 and run FM in DC it replaces the font with Times.

    I can also make a blank InDesign document with just a field and export using FM 3.0.8 and it strips the font.

    #6344 Reply
    Ariel
    Keymaster

    I’m not seeing any difficulty embedding Proxima Nova into form fields with FormMaker. It works fine, as expected, out of the box. I created a form on Windows with Proxima, and exported to interactive PDF via FormMaker, then opened it on my Mac (that does not have Proxima installed), and the fields have the correct font embedded in them.
    Are you using the Proxima Nova that comes as part of a Creative Cloud subscription, or is it a standalone font that you bought from elsewhere? (Not that it should matter either way, but certainly for me, testing on the Proxima that comes with CC, everything is working as expected.)
    I would double-check the text fields in InDesign (before running FormMaker on them) to see that you really have applied the font properly to them, either by adding some default text to the fields, or apply a paragraph style to them that has that font selected.

    #6345 Reply
    Ariel
    Keymaster

    (Also, make sure that your FontList.txt file is deleted, since you do not need it for this, and perhaps it is confusing things.)

    #6346 Reply
    Anagoge
    Participant

    I think it’s now fixed! I have no idea how though.

    Does it matter if I export the PDF via File > Export or via FormMaker’s “Create Interactive PDF” button? I’ve tried both while experimenting with things.

    Somehow things are okay again either way!

    #6347 Reply
    Ariel
    Keymaster

    Yes, it does make a difference. You have to use FormMaker’s button. It stores all your form info at the same time as creating the PDF. If you use File > Export it bypasses FormMaker. Perhaps that was the problem!

    #6348 Reply
    Anagoge
    Participant

    Sorry to come back to this again, but still can’t get the font issue solved. It seems to work intermittently.

    * The fields are all set to Proxima Nova in InDesign. See screenshot: https://i.imgur.com/TS6hFyU.png
    * I click “Create Interactive PDF”
    * I get FormMaker’s “Interactive PDF Export Options” window.
    * I click OK
    * Fields all have Proxima Nova prior to running FM in DC. See screenshot: https://i.imgur.com/Mmup7uz.png
    * I go to Edit > FormMaker.
    * Fields revert to Times. See screenshot: https://i.imgur.com/fSK568F.png

    I just can’t seem to get the font to be retained. As you can see, the format category is applied after running FM (See two decimal points after “123”), but the font isn’t.

    #6349 Reply
    Anagoge
    Participant

    I’ve figured it out!

    Even if I’ve set fields to Proxima Nova in InDesign, FormMaker requires me to manually click inside a field to ‘set’ it as Proxima.

    InDesign exports with Proxima with no problem. To get it to work with FormMagic, it’s obligatory to click inside every field first.

    I know some of the documentation mentions clicking inside fields to ‘set’ them, but I’m unsure if this also applies to fields that are already set by InDesign or if it’s a bug?

    #6350 Reply
    Ariel
    Keymaster

    Ah, now I understand! Yes, indeed. FormMaker ignores and overrides the font that is set in the Buttons and Forms panel. You have to set the font in the text frame that you’re using as a form field, in the regular way you set a font for text in InDesign.
    I’ll see if I can make that clearer in the Help page.

Viewing 19 posts - 1 through 19 (of 19 total)
Reply To: FormMaker fields retain “$” symbol even after specifying no symbol.
Your information: